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Tool Package Training – Mask Design (v1) 

  Exercises 
 

Exercise1: Getting started 
 
Install L-edit on your computer. 
 
You can find more information about mask design in the official manual L-Edit guide called Layout Editor 
that you find in the Help function of L-edit.  
 
The in Beginner guide to mask design using Clewin is also useful even though it contains specific guidance 
for Clewin users. 
 
Watch the introduction videos:  

L-Edit: https://www.youtube.com/watch?v=Ejtpzxd4ZzQ&list=PLZtOmgn4lTS4GXkBxXzulI7BR3KxOutm9 
 
Exercise guidance. Small exercises to ensure that you come around the basics of drawing in L-edit.  
 
1) For your own convenience it is good idea first to define your wafer size so that you do not draw outside 

the wafer limits. 
a) Select the Layer **** Special Utility Layers **** in the Layer menu to the left of the screen.  
b) Draw a circle with center (0,0) and the radius/diameter of your wafer (normally 100mm or 150mm) 
c) If you cannot find a circle on the toolbar then right 

click on the toolbar with an arrow, square, … 
 and select “All angle and curves” on the menu that 
pops up. Three more icons are now added to the 
toolbar. 
 

2) Choose a layer in the Layer menu (for instance layer “Active”). Make a rectangle that is 50 um wide and 
35 um high in layer 0. Place the rectangle such that the lower left corner is in the coordinates (-100, 0). 
Make a copy of the rectangle and place it such that the center is in the coordinate (-125,-25). Enlarge 
the rectangle with 50 % such that the upper right corner stays in the coordinates (-100,-7.5) and rotate 
it counterclockwise 45 degrees around the upper right corner. Make a shape that connects the two 
lower corners of the smaller rectangles with the two upper corners of rotated rectangles (You probably 
need to zoom to highest level to ensure no gap is present and that the corners actually overlap). Merge 
all three shapes into one shape (this act cannot be reversed). How many nodes does the shape consist 
of and how large is the area?  
 

3) Chose or define another layer and name it Layer 1. Change the color and pattern to your favorite in this 
layer. 

 
4) Make a rectangle that is 50 um wide and 35 um high in layer 1. Place the rectangle such that the lower 

left corner is in the coordinates (0, 0). Make another rectangle 10 um smaller on all edges and place it 
next to the first rectangle you made separated 20 um and aligned to the top. Combine the two 
rectangles in a Cell named Rectangles. Open “Design Navigator under the View pane. Here a hierarchy 
is shown where the Rectangles are below the MainSymbol named Cell0. 

 

http://labadviser.danchip.dtu.dk/images/f/f0/Beginner_guide_to_mask_design_using_Clewin_v1.31.pdf
https://www.youtube.com/watch?v=Ejtpzxd4ZzQ&list=PLZtOmgn4lTS4GXkBxXzulI7BR3KxOutm9
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5) Create a circle in the MainSymbol (Cell0) with a diameter of 200 um with a square hole in the center 
with an edge length of 80 um. Center the structure in (100,-200). How do you make the figure? 

 
6) By the way the circle should have been drawn in a layer named layer 2. 

 
7) Create a new Cell called Shapes: in the Main Menu Bar click Cell and then New. Change the name of the 

cell and click ok.  
 
8) By using the shaping tool create the 4 figures shown below in the symbol Shapes. The 1st shape from 

the left is roughly 150 µm wide and 200 µm high, the 2nd is 270  µm wide, the 3rd is 200 µm high and the 
outermost to the right is 200 µm high and 250 µm wide: 

 

(1)  
 
ii) Describe in words how you made the 4 shapes List from left to right.  
 

9) Open the design navigator and drag the symbol Shapes into the MainSymbol Cell0 and place it next to 
the circle with the square hole. If you expand cells in the design navigator window  the hierarchy of 
your design will appear in the window:  

 
i) You should now see two Cells (Rectangles and Shapes) at the same hierarchy level under the 

MainSymbol Cell0.  
 

10) To make and array of the smaller rectangle in the symbol Rectangles open the cell named Rectangles by 
double clicking the cell in the layout, in the design navigator or choose the cell from the list that 
appears in the menu under Cell open and make a new symbol of the smaller rectangle, named 
Rectangle_small. While staying in the symbol Rectangles duplicate the smaller rectangle in an array of 
100 rows and 80 columns separated with a 20 µm space in both directions. What happens in the array 
if you open the symbol Rectangle_small and change the size of the small rectangle by Crtl E? 
 

11) What happens if you open the symbol Rectangles and scale the array with a factor of 5 using Ctrl E, 
what if you scale with a factor of 0.5?  

 
12) Create an empty cell and name it Squares. Make a square 500x500 um in the empty cell with bottom 

left corner in (0,0) in Layer1. Make a smaller square (400 x 400 um) on top of the first square in Layer 
Active. Align the two squares around their common center point. Open Cell0 and instance the symbol 
Squares here and place it in the coordinate (0,-1000). Describe how you do this.  
 

13) Save the layout with a new name as a tdb file as well as a gds file and cif file. Before exporting the file 
you should give every single layer that you use in the layout a unique CIF name and GDS number. This is 
done in the setup layers or by double clicking the layer. Further the fabrication cell should be defined 
before saving/exporting. This is done by clicking Cell in the toolbar and chose fabricate. Then choose 
the cell to fabricate and click ok. You should now see a pink f left of the cell to fabricate (Cell0). 

 
14) Send the files to Kabi@danchip.dtu.dk and you can move on to Exercise 2 and 3 (see below). 

  

mailto:Kabi@danchip.dtu.dk
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Exercise 2: Design making 

In this step you are going to make a mask layout for a pressure sensor. An example of a pressure sensor is 
shown below.  
 
 
 
 
 
 
 
 
 
 
 
Left: a top view.                            Center: a cross sectional view.                      Right: a view from the backside.   
 
It will take 5 different masks (i.e. 5 different layers in the design file) to make the shown design; one for the 
interconnections, high boron doped; one for the piezo-resistors, low boron doped; one for the pressure 
membrane and finally one for the metal contacts. In the layout we have made the first 2 masks. Your task 
will be to complete the layout with 3 more masks; the membrane, contact holes and contact metal.  
 
A simplified process flow for the pressure sensor could be:  

1. RCA Clean wafers 
2. Thermal oxidation of wafers 
3. LPCVD nitride deposition 
4. Photolithography on front side.  

Mask 1: open holes in nitride and oxide for high boron doping 
5. Etch nitride and oxide on front side 
6. Resist strip 
7. RCA Clean wafers 
8. Boron doping p++ 
9. Photolithography on front side. 

 Mask 2: open holes for low boron doping  
10. Etch nitride and oxide on front side.  
11. Resist strip 
12. RCA Clean wafers 
13. Boron doping p+, the p++ area will also be p+ doped in this step 
14. Thermal drive in and oxidation 
15. LPCVD Nitride deposition 
16. Photolithography on back side.  

Mask 3: open hole on back side for membrane etching 
17. Etch nitride and oxide on back side only 
18. Resist strip 
19. KOH etch of Silicon 
20. Photolithography on front side.  

 Mask 4: open contact holes 
21. Etch nitride and oxide on front side 
22.  Photolithography on front side. Negative tone resist. 

 Mask 5: define metal contacts 
23. Evaporate metal 
24. Lift-off process  

4 mm 

4
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m
 

Silicon n-type 
SiO2 
Boron, p+ 
Boron. p++ 
Nitride 
Metal 

•  Mask1 High boron doping, 
P++ 

•  Mask2 Low boron doping, 
P+ 

•  Mask3 Membrane 
•  Mask4 Contact holes 
•  Mask5 Metal contacts 

3
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After step 8 

After step 13 

After step 15 

After step 19 

After step 24 
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Exercise guidance. Getting started with the pressure sensor design: 
 

 
1. Start to open the file Exercise pressure sensor.tdb. Open the design navigator and you will see the 

hierarchy of cells already made. The MainSymbol is empty.  
For your own convenience it is good idea first to define your wafer size in the MainSymbol so that 
you do not draw outside the wafer limits: 

a. Select the Layer **** Special Utility Layers **** in the Layer menu to the left of the screen.  
b. Draw a circle with center (0,0) and the radius/diameter of your wafer (normally 100mm or 

150mm) 
c. If you cannot find a circle on the toolbar 

then right click on the toolbar with an arrow, 
square, … 
 and select “All angle and curves” on the 
menu that pops up. Three more icons are 
now added to the toolbar. 

 
2. You can now instance the cell SensorDie in the MainSymbol. Either by dragging the cell from the 

Design Navigator into the MainSymbol or by pressing I while having MainSymbol active and then 
select the cell SensorDie from the list that pops up. 
 

3. Define a layer in which the membrane should be made and draw the membrane in an appropriate 
Cell. The opening for the membrane has to be larger than the final membrane size, due to the 
nature of the used etch (KOH) and it should be centered such that the strain gauges are close to the 
edge of the membrane still allowing for a possible misalignment of 5-10 um. (A membrane opening 
of 850µm x 850µm will result in a membrane size of 410 µm x 410 µm in a 311 µm deep KOH etch). 

 
4. Define layers for the masks forming the contacts of the pressure sensor. The metal contacts should 

be 500 µm x 500 µm and the contact hole should be somewhat smaller to ensure fully coverage of 
the hole with metal in case of misalignment. The contacts should be placed close to the die edge on 
top of the Boron p++ layer in order to ease the interconnection with gold wires to a substrate for 
electrical measurement. A cross sectional drawing of a contact is shown below: 
 
 
 
 
 
 

 
 
 

5. The SensorDie should be duplicated such that approximately 400 dies is centered on the wafer. The 
die size should be 4 x 4 mm. Remember to make space for the dicing lane, which will require 100 
µm between each die. 

 
 

  

Silicon n-type 

Boron p++ 

Nitride 
SiO

2
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Wafer layout  
 
Mask definitions 
Before making the alignment marks it is a good idea to consider the mask definitions first. An example of a 
set of mask definitions is shown below. All layers are made as 5” masks (for 4” wafers). The masks are made 
of Soda-lime glass with a dark periphery. The periphery and the design patterns are defined in Chromium. 
Each layer then has its own set of definitions: Chrome Up (CU) or Chrome Down (CD), Right Reading (RR) or 
Wrong Reading (WR), Bright Field (BF) or Dark Field (DF). In the example below all three layers are defined 
with the chromium downwards (CD): 
 

All Layers: 
5" chromium mask 
Soda-lime Glass 
Dark periphery 
Chromium Down 
 
Filename: TPT-maskset.cif (it can also be a gds file) 
Topcell or Mainsymbol: (name of the cell to be fabricated, often it is named Wafer) 
 
Layer name: mask1 (for cif files it is the CIF name assigned to the specific layer and for gds 
files the name is the number assigned to the specific layer) 
Mask type: Dark Field, Right Reading 
Text: DTU Danchip – Karen Birkelund - August 2016 - Projectname – Nitride etch 
 
Layer name: mask2 
Mask type: Bright Field, Right Reading 
Text: DTU Danchip – Karen Birkelund -  August 2016 - Projectname – Deep Si Etch 
 
Layer name: mask3 
Mask type: Bright Field, Wrong Reading 
Text: DTU Danchip – Karen Birkelund - August 2016 - Projectname – Metal  
 

Each mask layer in the file has to be addressed. The text is an identifier that will be written in the edge of 
the mask for your information only and will hence not appear on the wafers. Notice that the definitions are 
made for all layers with Chromium Down. Then right reading masks are for one side of the wafer while 
wrong reading masks are for the other side of the wafer. 
 
Alignment  
 
All the individual layers in the design need to be aligned to each other in the order they are processed.  
It can be a good idea to define all alignment marks in the 1st mask, such that all forthcoming masks can be 
aligned with the same accuracy to the first mask. However, sometimes it can be convenient that for 
instance the 4th mask is aligned more precisely say to the 2nd mask than to the 1st. I that case a new marks 
can be defined on the 2nd mask such that aligning the 4th mask is independent of the misalignment of the 
2nd mask to the 1st mask.  
It cannot be recommended to have only one single mark for all masks to be aligned to, because it can be 
quite difficult to preserve the mark during processing, especially in deep etches. You can find design rules 
for the alignment marks in Beginner guide to mask design using Clewin 
 
 
 

http://labadviser.danchip.dtu.dk/images/f/f0/Beginner_guide_to_mask_design_using_Clewin_v1.31.pdf
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Monitor structures 
It is wise to incorporate monitor structures on a mask design for the individual processing steps.  
 
In the folder Library you will find different patterns like alignment marks, flat alignment marks and monitor 
structures and test dies for electrical measurements. You are free to use these in your layout or you can 
make your own. 
 
 

Exercise 3 - Making the overall wafer layout 

 
1. Make and place monitor dies at strategic positions in the mask design. Argue why they are placed 

as it is. 
 

2. Incorporate guiding marks for the dicing in an appropriate layer. 
 

3. Make flat alignment mark in your mask design, this should be on the first mask to be processed. 
 

4. Make alignment marks for each layer in the mask design. You want to align with high accuracy (1-3 
µm). Remember that the polarity of the mask influence the way they are made, since you need to 
be able to see what is on the wafer beneath the mask you are going to align to. Also remember that 
the field in an aligner typically is 300 µm x 300 µm. 

 
5. Where there is room you can place your name and other fun stuff as Global ID’s 

 
6. By the way it has been decided that the contact holes on all sensor dies should be circular with at 

diameter of 400 µm, while the metal contact should remain as a square.  
 

7. We also need to know the fraction of the surface of a 4”wafer (diameter 10 cm) that is covered 
with metal in the design. L-Edit has an area calculator, choose Tools->Add-Ins->Area 
calculator in the menu bar. Before making the calculation you should save a copy of your 
design, flatten your design by choosing Cell->Flatten in the menu bar (this action cannot be 

reversed, why you should do this action in the copy of your design), make the layer which area you 
want to calculate visible, all other layers should be invisible, mark the area that should be 
calculated and execute the calculator. You should be aware that the calculated fraction 
(percentage) is with respect to your defined rectangle and not a disc like a wafer. Do the calculation 
with respect to a 4” wafer. You can ignore the wafer flats in the calculation. 
 

8. Export the file as a cif file as well as a gds file. When saving in cif or gds formats it is important that 
all layers used in the layout have a unique CIF name or unique GDSII-number. You can check that 
out by for each layer used in the layout in the Setup Layers choose general and type a number in 
the GDSII number field and a CIF name in the dedicated field. 

 
Finally you are ready to make a mask order. 
 

 Write a text file with the mask specifications as shown in the example. A negative tone photoresist is 
used for the mask defining the metal pads followed by a lift off (the areas that are exposed to light will 
the area with metal after the lift off). The other masks are to be used with a positive tone photoresist 
(the areas that are exposed to light will be openings in the resist). 
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 Send a mail with the text file containing the mask definition together with a cif- or gds-file with your 
layout attached to Mask@danchip.dtu.dk. In the subject field of the mail you write “TPT Course: 
maskorder”. 

 

 

 

mailto:Mask@danchip.dtu.dk

